Caixa de diálogo Início de sessão no SQL Server

O Microsoft® SQL Server™ OLE DB Provider mostra a caixa de diálogo Início de sessão no SQL Server quando for tentada uma ligação de OLE DB sem que se especifiquem informações suficientes para que o controlador consiga ligar a um servidor de SQL.

Quando a caixa de diálogo Início de sessão no SQL Server é apresentada pela primeira vez, contém apenas o seguinte:

Caixa Servidor.

Caixa de verificação Utilizar ligação fidedigna.

Caixa ID de início de sessão.

Caixa Palavra-passe.

Botões OK, Cancelar, Ajuda e Opções.

Se clicar no botão Opções, a caixa de diálogo aumenta de modo a conter também o grupo Opções:

Caixa Base de dados

Caixa Idioma

Caixa Nome de aplicação

Caixa ID da estação de trabalho

Caixa Servidor

O nome de um servidor de SQL existente na rede. Se seleccionar o nome de um servidor na lista, não será necessária uma configuração adicional. Se escrever um nome de servidor, tem de ser uma entrada avançada no utilitário SQL Server Client Configuration ou o nome de rede de um servidor com o SQL Server.

Pode escrever "(local)" na caixa do servidor quando estiver a utilizar o mesmo computador como servidor de SQL. Depois, o utilizador pode estabelecer ligação com uma cópia local do SQL Server, mesmo quando estiver a ser executada uma versão do SQL Server que não esteja em rede. Para especificar uma determinada ocorrência do SQL Server, o nome do servidor é especificado como NomeServidor\NomeOcorrência.

Para mais informações sobre nomes de servidores para diferentes tipos de rede, consulte a documentação de instalação do SQL Server em SQL Server Books Online.

Caixa de verificação Utilizar ligação fidedigna

Quando seleccionada, especifica que o fornecedor de OLE DB para SQL Server pedirá uma ligação segura (ou fidedigna) a um SQL Server em execução no Microsoft Windows NT® ou no Microsoft Windows 2000. Quando seleccionada, o SQL Server utilizará a segurança integrada de início de sessão para estabelecer ligações utilizando esta origem de dados, independentemente do modo actual de segurança de início de sessão existente no servidor. Será ignorado qualquer ID de início de sessão ou palavra-passe fornecida. O administrador de sistema do SQL Server tem de ter o seu início de sessão do Microsoft Windows® associado a um ID de início de sessão no SQL Server.

Quando desmarcada, o SQL Server utiliza a segurança padrão de início de sessão para estabelecer ligações utilizando esta origem de dados. Tem de especificar um ID de início de sessão e uma palavra-passe para todos os pedidos de ligação.

Caixa ID de início de sessão

Especifica o ID de início de sessão no SQL Server a utilizar para a ligação se não estiver seleccionada a caixa Utilizar ligação fidedigna. Se a caixa Utilizar ligação fidedigna estiver seleccionada, a caixa ID de início de sessão está desactivada.

Caixa Palavra-passe

Especifica a palavra-passe para o ID de início de sessão no SQL Server utilizada para a ligação se não estiver seleccionada a caixa Utilizar ligação fidedigna. Se a caixa Utilizar ligação fidedigna estiver seleccionada, a caixa Palavra-passe está desactivada.

Caixa Base de dados

Especifica a base de dados predefinida a utilizar na ligação. Esta base de dados substitui a base de dados predefinida especificada para o início de sessão no servidor. Se não for especificada nenhuma base de dados, a ligação utilizará a base de dados predefinida especificada para o início de sessão no servidor.

Caixa Idioma

Especifica o idioma nacional a utilizar para as mensagens de sistema do SQL Server. O SQL Server tem de ter o idioma instalado. Este idioma substitui o idioma predefinido especificado para o início de sessão no servidor. Se não for especificado nenhum idioma, a ligação utilizará o idioma predefinido especificado para o início de sessão no servidor.

Caixa Nome de aplicação

Especifica opcionalmente o nome da aplicação a armazenar na coluna program_name na linha desta ligação em master.dbo.sysprocesses.

Caixa ID da estação de trabalho

Especifica opcionalmente o ID da estação de trabalho a armazenar na coluna hostname na linha desta ligação em master.dbo.sysprocesses.

©1988-2000 Microsoft Corporation. Todos os direitos reservados.


Copyright e exclusão de responsabilidade do Microsoft SQL Server 2000

Este documento, incluindo as aplicações exemplo, destina-se apenas a fins informativos e a Microsoft não concede nenhuma garantia, expressa ou implícita, neste documento. As informações contidas neste documento, incluindo exemplos, URLs e outras referências a Web sites da Internet, estão sujeitas a alterações sem aviso prévio. Todos os riscos de utilização ou dos resultados da utilização deste documento são da responsabilidade do utilizador.

O objectivo principal de um exemplo consiste em ilustrar um conceito ou uma utilização aceitável de uma determinada instrução ou cláusula. A maior parte dos exemplos não inclui a totalidade do código que seria normalmente encontrado num sistema completo, dado que muita da habitual validação de dados e do tratamento de erros é removido para destacar no exemplo um determinado conceito ou uma instrução. Não está disponível suporte técnico para estes exemplos ou para o código fonte fornecido.

Os nomes de empresas, organizações, produtos, pessoas e eventos mencionados neste documento são fictícios e não se destinam, de todo, a representar qualquer empresa, organização, produto, pessoa ou evento real, salvo indicação em contrário. A conformidade com todas as leis de copyright aplicáveis é da inteira responsabilidade do utilizador. Sem limitação dos direitos protegidos por copyright, nenhuma parte desta publicação deverá ser reproduzida, armazenada ou introduzida num sistema de recuperação ou transmitida de alguma forma ou por qualquer meio (electrónico, mecânico, através de fotocópia, gravação ou outros) ou para qualquer finalidade, sem a permissão por escrito da Microsoft Corporation.

Nesta publicação, a Microsoft pode ter patentes, pedidos de patente pendentes, marcas comerciais, copyrights ou outros direitos de propriedade intelectual. Com excepção do estipulado expressamente em qualquer acordo de licenças escrito pela Microsoft, o facto de este documento lhe ser fornecido não lhe confere quaisquer direitos sobre essas patentes, marcas comerciais, copyrights ou outras formas de propriedade intelectual.

©1996-2000 Microsoft Corporation. Todos os direitos reservados.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, Microsoft SQL Server, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Visual Studio, Win32, Windows 2000, Windows e Windows NT são marcas registadas ou comerciais da Microsoft Corporation nos Estados Unidos e/ou noutros países.

Os nomes das empresas e produtos reais mencionados nesta publicação podem ser marcas comerciais dos respectivos proprietários.

Versão: 8.00.000

©1988-2000 Microsoft Corporation. Todos os direitos reservados.